Linux Git安装

场景

一般来说linux安装通过yum或者apt-get命令安装即可,但是使用此类命令,git安装版本太低了,因此需要编译安装

源码安装Git

  • 查看https://github.com/git/git/releases版本
  • 选择需要下载的版本地址,比如2.32.1,复制链接地址

复制链接地址

  • 下载并解压,安装所需依赖,编译
# 下载
wget https://github.com/git/git/archive/refs/tags/v2.32.0.tar.gz
# 解压
tar -zxvf v2.32.0.tar.gz
# 安装所需依赖(如果编译出现确实依赖,按此方法安装即可)
yum install curl-devel expat-devel gettext-devel openssl-devel zlib-devel gcc perl-ExtUtils-MakeMaker
# 编译
cd v2.32.0.tar.gz && make prefix=/usr/local/git all
# 安装
make prefix=/usr/local/git install
  • 设置环境变量
vim etc/profile
# 添加环境
export PATH=$PATH:/usr/local/git/bin
  • 安装完成
# 查看安装的git版本,校验通过,安装成功
git version
: )